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IME-100, ECE Lab1 

Circuit Design, Simulation, and Layout 

In this laboratory exercise, you will do the following: 

 

• Use a Schematic Capture program, NI Circuit Design Suite; 

  Multisim, to draw an LM555 based traffic light circuit. 

• Use the simulation capabilities of the program, NI Circuit Design 

  Suite; Multisim, to simulate the traffic light circuit operation. 

• Observe how the timing of the traffic light circuit can be  

  controlled using a variable resistor. 

• Investigate circuit board layout using the program, NI Circuit 

  Design Suite; Ultiboard. 
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Getting Started 
 

1. Laboratory Computers 

i. Log-in with User Name: Kettering Student               

(no password required) 

ii. IME-100 information (Lab presentation, files, etc.) in 

folder on desktop 

iii. NI programs (MultiSim, Ultiboard) under the Start 

menu 

iv. At the end of lab, Logout of computer; arrange 

keyboard and mouse 

2. Laboratory Instrumentation 

i. Use instrumentation only when instructed 
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LM555 Based Traffic Light Circuit 
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LM555 Based Traffic Light Circuit 

LM55CN 

 Timer IC 

Resistors 

R1,R2,R3 

Ground 

Capacitors 

C1,C2,etc. 

Oscilloscope 

Instrumentation 

5 Volt DC Power 

Supply 

Light emitting 

diodes (LEDs) 

Header pins to 

connect Power 

Supply and Scope 

Potentiometer 

Variable Resistor 
Decimal 

counter IC 

Logical OR 

gate (4-inputs) 
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 The operation of the LM555 

Formula for high time t1, low time t2, and period T : 

𝑡1 = 0.693 ∗ 𝑅1 + 𝑅2 ∗ 𝐶 

𝑡2 = 0.693 ∗ 𝑅2 ∗ 𝐶 

𝑓 =
1

𝑇
=

1.44

𝑅1 + 2 ∗ 𝑅2 ∗ 𝐶
 

𝑇 = 𝑡1 + 𝑡2 = 0.693 ∗ 𝑅1 + 2 ∗ 𝑅2 ∗ 𝐶 

Example: If R1 = 4.7 KΩ, R2 = 27 KΩ 

And C = 50 µF, calculate t1, t2, T, and f 
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 The operation of decimal counter 4017 

outputs pulses 

The circuit uses LEDs to show count of the number 

of pulses applied by using the switch 
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 The operation of logical OR gate 4072 

A B C D Q 

0 0 0 0 0 

0 0 0 1 1 

0 0 1 0 1 

0 0 1 1 1 

0 1 0 0 1 

0 1 0 1 1 

0 1 1 0 1 

0 1 1 1 1 

1 0 0 0 1 

1 0 0 1 1 

1 0 1 0 1 

1 0 1 1 1 

1 1 0 0 1 

1 1 0 1 1 

1 1 1 0 1 

1 1 1 1 1 

Truth Table for a Single Gate 

clock Green 

Red 

Yellow 

clock 

Green 

Yellow 

Red 

0   1    2   3   4    5    6   7   8   0   1    2   3   4 
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Start NI Circuit Design Suite: Multisim 

• Find icon on desktop (shown here for Multisim 11.0) 

• Multisim start-up screen takes a few moments to load, …Please Wait. 

Part 1) Multisim Schematic Capture 

 and Simulation 

Multisim 11.0 
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Schematic drawing workspace 

Component menu 

Tool bar and pull-down menus 

Simulate Pause 

Simulate On/Off 

Instrument menu 

•A blank file opens with the 

workspace called“Circuit1” 

•Save this file (Select File/Save 

As) to a location you desire (or 

the default location) using a file 

name of your choice (e.g. 

IME_100_TLight). 

NOTE:  All files saved 

on the lab computer 

harddrives are DELETED when 

you logout. 
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Select the Components 
• Select the components for the 

circuit from the components 

menu along the top and the 

oscilloscope instrument from the 

instruments menu on the right 

side. 

• Power and Ground are in the 

Sources menu (left-most icon. 

• Resistors, Capacitors, and 

switches are in the Basic menu 

(second from left). 

• LM555N timer IC is in the 

Mixed menu (ninth from left). 

• If you don’t find a part, you can 

search for it in the database (such 

as in the Master Database), 

Select all groups, then write the 

identifier in Component: textbox.  
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Place the Components 

 

• Select the components 

for the circuit from the 

appropriate menus. 

• Click anywhere on the 

workspace to place them. 
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Arrange the Components 

• After they are placed, arrange the components (Click and Drag) 

as you want them to appear in the final schematic. 

• Rotate components with Ctrl R 

1-13 G. Tewolde, IME100-ECE, 2017 



Wire the components together  

• Point to where the wire is to begin (a cross-hair dot will appear), then Click to 

place a junction. 

• Move the cross-hair dot to where the wire is to end, then Click to place another 

junction. 
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 Complete Circuit 
• When the circuit is complete, turn off the Grid, Select View → 

uncheck Show Grid . 

• Select Place [ Title Block. Open the title block file,                 

IME100-lab1-title.tb7 and place it in the lower right hand corner. 

• Double Click on the title block to open the title block editor. 

• Change Title to “IME-100 ECE”; enter the description “Traffic 

Light Control Circuit”; Designed by:,Checked by:, and Approved 

by:, to members of your group. 

•Print a hardcopy of the circuit schematic. Click the Print Circuit 

icon. 
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 Your printed schematic 

should look something 

like this…. 
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Adjust Y position 

Of channels: 

A=1.8, B=0.4, C = -1.4, D = -2.8 

Circuit Simulation 

• Double Click on the 

oscilloscope to open the 

oscilloscope window. 

• Change Channel A, B, C, 

and D, Y positions to 1.8, 0.4, 

-1.4, and -2.8, respectively. 

• Go to Simulate->Interactive 

Simulation Settings, change 

the set maximum time step 

(TMAX) to 1e-003 or 0.001 

• Start the simulation using 

the Simulation On/Off button. 

• You can pause the 

simulation using the pause 

button next to the On/Off 

button. 

• From the oscilloscope 

traces, measure frequency of 

the clock, and the time 

duration of each of the traffic 

signals. 

Simulation On/Off 

Select channel for  

adjustment 
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Circuit Simulation 

• Change the value of the potentiometer (variable resistor) to 25% value. 

• Observation what happens to the clock frequency and the time duration of the traffic signals.  

• Achieve a representative oscilloscope trace similar to the one shown above, then press the 

Pause Simulation button. 

• Print the oscilloscope display window for each of the 50% and 25% settings of potentiometer. 
Under the File menu, select Print Options → Print Instruments, then select Oscilloscope – XSC2 and Print. 

Move this slider to change the 

potentiometer value 
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 Your printed instrument 

screen should look 

something like this…. 

 

From your simulation, 

calculate : 
1) Clock frequency 

2) Green signal time duration 

3) Yellow signal time duration 

4) Red signal time duration 

 
Answer the above questions 

for each of the following two 

settings on the potentiometer: 

a) 50% 

b) 25% Use the time markers for 

measuring time between two 

edges in the waveform 

You can click and move the time markers 1 and 2, or use the 

left and right arrows next to T1 and T2 to move them step by 

step. Also, you can select a time marker with a left mouse 

click, and use the menu commands from right mouse click. 
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Part 2) Ultiboard PCB Layout 

Start NI Circuit 

Design Suite: 

Ultiboard 

•Ultiboard start-up 

screen.  (takes a 

few moments to load) 

…Please Wait… 

• Open the PCB Layout file named IME100_Tlight.ewprj 

Ultiboard 11.0 
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Board Outline 

LEDs and 

Potentiometer 

not yet placed  

on board. 

Ratsnest of net 

connections 

Enable Selecting 

Parts 
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The Traffic Light printed 

circuit board outline is shown  

with most of the components 

placed except the LEDs and 

potentiometer. 

• Enable Selecting Parts 

• Place the Potentiometer and 

LEDs on the board where 

indicated by the white outlines 

(click and drag). 

• Note that all of the circuit 

  net connections are shown 

  with yellow lines (called 

  a Ratsnest). 



With the components 

properly placed, convert 

the ratsnest of net 

connections into copper 

traces on the board using 

Ultiboard’s Autorouter 

feature. 

Select Autoroute → 

    Start/Resume Autorouter 

or click the Autoroute icon 
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Red – Bottom Layer 

Copper 

Green – Top Layer 

Copper 

The Autorouter finds a 

viable way of making all 

the net connections with 

traces of copper on the top 

and bottom of the board 

subject to a set of Design 

Rules. 

• Copper traces on top of the 

 board are Green lines 

• Copper traces on bottom of 

  the board are Red lines 

• There are a few Vias required. 

 (Vias are plated holes 

 connecting top and bottom 

 copper traces that allow 

 cross-over points.)  

 Can you find at least one via? 
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Make a printout of 

your Traffic Light 

PCB layout. 

• Select File → Print 

• Print only the Board 

Outline, Silkscreen 

Top, Copper Top, and 

Copper Bottom layers 

(all layers on the same 

sheet of paper). 

• On your printout, 

highlight at least one 

via placed by the 

autorouter. 
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Investigate what your board 

might look like after fabrication 

using Ultiboard’s 3D View 

feature. 

 

• Select Tools → View 3D 

   or click on the Show 3D icon 

• Use the mouse to move the 

  board to view different 

  perspectives. View both the 

  Top and Bottom of the board. 

• Make a printout of a 

 representative 3D view of the 

 top of your board.aboratory. 

Board 

Bottom 

Board 

Top 
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Page 1 

Page 2 

Your calculation of the clock  

frequency and duration of the  

Green, Yellow, and Red traffic 

signals as determined from the  

Oscilloscope trace for 50%  

Setting on the potentiometer: 

 

fclock = ___________(Hz) 

 

Green on   = _______ (sec) 

Yellow on = _______ (sec) 

Red on      = _______ (sec) 

Page 3 

Page 4 

3D view of the Traffic Light PCB layout 

- Top of board. 

Highlight at least  

one via on your 

PCB layout. 

Example Report: 

Also give a second waveform and the same 

calculations for potentiometer setting of 25% 



Due: Beginning of 2rd Week Lab 
 

Think about other useful and practical 

applications of a timer or clock. Explore all 

possible scenarios such as in personal, 

household, industrial, and other 

applications. 
 

Research and brainstorm your ideas with 

your lab partners to cover many possible 

applications, including potentially new ones. 
 

Turn in a one page report for your answers. 
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Homework: For the Curios You … 
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Finishing Up 
(and to get full-credit in the lab) 

1. Clean-up bench – Leave it better than you found it! 

i. Pick-up any spare parts, wire-trimmings, etc 

ii. Detangle and coil wires 

iii. Logout of computer; arrange keyboard and mouse 

iv. Neatly arrange the chairs 

2. Check-out with the instructor 

i. Submit your lab report 

ii. Leave the check-out sheet with your group names at 

your station 
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Lab 1 Check-Out Sheet 
(to be left on the bench at the end of lab) 

Group Members (please print name clearly): 

Instructor (check all that apply): 

□ Laboratory Report Submitted 

□ Computer Logout 

□ Bench clean-up 

 Wires, detangled and coiled, 

 Keyboard, Mouse, Instruments, etc. 

 Chairs arranged 
 

Additional Comments: 
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